piątek, 30 września 2016

Octopi z GIT w Archu - errata

Od czterech dni nie zbudujemy już octopi z GIT w Archu (ani w żadnym innym systemie) niezależnie czy będziemy używać PKGBUILDu dostępnego w AUR, czy też u mnie. "Winę" za taki stan rzeczy ponosi zmiana dokonana w kodzie programu, który obecnie jako swoją zależność wymaga również alpm_octopi_utils, czyli Alpm dla Octopi. Autor oczywiście stosowny kod zrobił, a nadto dostarcza również PKGBUILD dla niego. Wystarczy w zasadzie pobrać powyższej zlinkowany PKGBUILD, umieścić go w jakimś katalogu, a następnie zbudować i zainstalować paczkę przed budową Octopi.
Lekko zmienione PKGBUILDy dla Octopi udostępnię prawdopodobnie dzisiaj, choć po zbudowaniu wyżej wymienionej paczki i jej zainstalowaniu w systemie, wszystkie programy Octopi budują się prawidłowo.

EDYCJA:
Skrypty PKGBUILDów zostały zaktualizowane. Dostępne są z poprzedniego wpisu.