czwartek, 31 marca 2016

Kate 16.03.80 przestaje funkcjonować po dzisiejszej aktualizacji

Jeśli ktoś dzisiaj zaktualizował system i jednocześnie ma:

  • włączone repozytorium [kde-unstable] i używa KDE-Applications 16.03.80,
  • włączone repozytorium [testing] (to akurat nie jest bardzo istotne tym razem),
  • używa kate/kwrite,
to może się spotkać z niemiłą niespodzianką w postaci braku możliwości uruchomienia co najmniej kate. Trzeba przebudować kate na podstawie dostarczonych do systemu libgit2 i kdetexteditor.
W tym celu musimy ściągnąć skrypty budujące kate:
yaourt -G extra/kate
extra, albowiem inaczej yaourt nie ściągnie.
Przechodzimy do katalogu kate i zmieniamy:

  • pkgver z 15.12.3 na 16.03.80,
  • pkgrel z 1 na 2,
  • w linii source wymieniamy "stable" na "unstable"
Zamykamy plik i wydajemy polecenia:

updpkgsums && makepkg -sirc
Od tej pory możemy się cieszyć działającym kate w wersji 16.03.80 (czyli 16.04 beta).

EDIT:
W repozytorium jest już dostępna wersja 16.03.80-2, która została przebudowana i problem opisany wyżej już nie występuje.