Przejdź do głównej zawartości

KDE Applications 16.08Beta

Właśnie ukazała się nowa odsłona aplikacji od KDE. Oczywiście dzięki arojasowi jest już dostępna dla Archa w repozytorium [kde-unstable]. Jeśli ktoś chciałby z niej skorzystać, to przypominam, że należy uruchomić to repozytorium oraz repozytorium [testing] albowiem programy trafiające do [kde-unstable] są budowane na podstawie aplikacji mieszących się właśnie w testing. W pliku /etc/pacman.conf należy zatem usunąć znak "#" przed [testing] oraz figurującym pod nim "Include = /etc/pacman.d/mirrorlist" oraz najlepiej na samej górze listy udostępnionych repozytoriów dodać:
[kde-unstable]
Include = /etc/pacman.d/mirrorlist

Z informacji niezbyt miłych:
- Blogilo nie potrafi jak na razie używać protokołu Bloggera - konieczna jest nowa biblioteka libkgapi,
- nie działają kody QR w kaddressbook - wersja prison nie jest kompatybilna z Plasmą,
Jak zwykle w przypadku udostępniania przez arojasa paczek w kde-unstable nie są dostępne pliki lokalizacyjne. Jeśli ktoś ich potrzebuje, to udostępniłem PKGBUILD, ale wyłącznie dla polskiej wersji językowej.
Do sierpnia błędy te winny być naprawione, a na pewno wraz z publikacją KDE Applications 16.08 arojas udostępni też kde-l10n.

Jeśli ktoś oczekiwał spektakularnego przeportowania pozostałych aplikacji należących do rodziny KDEApps do KF5, to może się rozczarować. Przeportowaniu uległy wyłącznie kdf, kolourpaint oraz cervisia. Oznacza to, że np. okular dalej oficjalnie jest w wersji nieprzeportowanej. A mijają już dwa lata od czasu publikacji KF5 i Plasma 5.

Znakomita większość paczek odpowiada ostatnio opublikowanej stabilnej wersji 16.04.3. Największe zmiany zaszły w Ark, który w końcu staje się pełnoprawną aplikacją do archiwizacji plików oraz KDEPIM, gdzie "wypadła" jednolita biblioteka kdepimlibs, która została podzielona na trzy inne. Powinno to umożliwić większe możliwości dostosowania do siebie aplikacji sładających się na KDEPIM i mniejsze ich zależności.

W przypadku znalezienia błędów w paczkowaniu, prosimy o ich zgłaszanie na bugzilli Archa z dopiskiem [kde-unstable], zaś w samych aplikacjach na bugzilli KDE.

Popularne posty z tego bloga

MEGA a sprawa Arch Linux

Mniejsza o to, czy MEGA to popularny, czy godny zaufania itd. itp. dostarczyciel przestrzeni w chmurze. Fakt, że po moich doświadczeniach z dropboksem nie chcę mieć więcej z nim nic wspólnego. Może zatem MEGA, do którego mam dostęp niemal od samego początku? Miłym dodatkiem do MEGA może okazać się uruchomione repozytorium oferujące sam program synchronizujący (megasync) oraz dodatki dla trzech, chyba najpopularniejszych, menedżerów plików: Dolphin, Nautilus i Thunar, umożliwiające synchronizację z plików z ich poziomu. Jest to o tyle miłe, że do tej pory musieliśmy kompilować te programy z AUR, a nadto w przypadku megasync wersja oferowana w repozytorium jest nowsza, zaś dolphin-megasync obecnie w ogóle się nie kompiluje. Chcąc dodać repozytorium MEGA do pacmana, edytujemy plik /etc/pacman.conf i gdzieś na końcu listy dodajemy: [DEB_Arch_Extra]SigLevel = Optional TrustAllServer = https://mega.nz/linux/MEGAsync/Arch_Extra/x86_64/ Nadto musimy jeszcze dodać klucz: gpg --receive-keys BF…

Plasma i Strażnik Krypt

W czasach, gdy nasza prywatność jest wystawiana na ciężką próbę, jeden z deweloperów KDE postanowił dodać do Plasmy możliwość dość łatwej obsługi szyfrowanych, wirtualnych "katalogów" - krypt, jak je nazywa. Sam projekt nazywa się plasma-vault i po około 3 miesiącach rozwijania pojawiła się w repozytorium unstable KDE najpierw jego wersja 5.9.95, a obecnie 5.9.96. Jak wskazuje numer wersji (choć ten został nadany nie przez opiekuna, ale przez wszędobylskiego Jonathana Riddella), aplikacja była planowana jako część Plasma 5.10. Tak się jednak z jakichś przyczyn nie stało. Obecnie jest ona planowana, jako część nadchodzącego wydania 5.11. Sam program w Archu dostępny jest w AUR. Buduje się całkiem żwawo i działa na tyle, by można zaryzykować jeśli nie używanie, to przynajmniej sprawdzenie działania i zgłoszenie ewentualnych błędów deweloperom. Pamiętajcie by czytać to co po pacman pisze przy instalacji. Program do prawidłowej funkcjonalności potrzebuje bądź encfs bądź cryfs. …

Co naprawdę oznacza, że pacman (Arch) nie wspiera częściowej aktualizacji

Pośród osób pracujących na Arch Linux jak mantra powtarzane jest twierdzenie: pacman (Arch) nie wspiera częściowej aktualizacji. Co w istocie to oznacza? Jakie są najczęściej popełniane błędy?

1. Synchronizacja repozytoriów dla zabawy
Zdarzyło się Wam wydać polecenie pacman -Sy bądź pacman -Syy, a za jakiś czas instalować program poprzez pacman -S? Jeśli nie, to jak dowodzą świadectwa innych użytkowników tu i ówdzie rozsiane po internecie praktyka ta wcale nie jest tak rzadka. Zobaczmy zatem co się dzieje w takich przypadkach i do czego to prowadzi.
Pierwsze polecenie dokona synchronizacji informacji o dostępnych paczkach (w tym ich wersjach) w repozytoriach z informacjami lokalnie przechowywanymi w bazie pacmana. Nie jest dokonywana żadna aktualizacja systemu. Następne polecenie oczywiście zainstaluje paczkę. Paczkę w takiej wersji, jaka jest w danym momencie w repozytorium.
Zwróćmy teraz uwagę na to w jaki sposób budowane są paczki w repozytoriach Archa oraz jakie informacje przekaz…