niedziela, 9 października 2016

Qt5-webengine 5.7.0-4 psuje aplikacje sieciowe

Wczoraj do repozytoriów trafiła przebudowana wersja paczki qt5-webengine 5.7.0 oznaczona nr 4 (5.7.0-4). Powodem jej przebudowy jest nowa wersja jsoncpp (1.7.7), która również wczoraj pojawiła się w repozytoriach. Instalacja nowej wersji qt5-webengine spowoduje brak możliwości korzystania prawodopodobnie z jakiejkolwiek aplikacji wykorzystującej ten silnik. Sprawdziłem na QupZilla, Otter-Browser (z tym silnikiem), KMail. Wszystkie te aplikacje wprawdzie uruchamiają się, jednakże nie wyświetlają żadnej treści.
Do czasu rozwiązania problemu, należy się zatem powstrzymać z aktualizacją tych paczek i dodać je (tymczasowo) do pola IgnorePkg w /etc/pacman.conf.
Osoby, które już dokonały aktualizacji i spotkały się z błędnym działaniem dotychczas prawidłowo działających aplikacji sieciowych, powinny dokonać cofnięcia wersji do qt5-webengine 5.7.0-3 oraz jsoncpp do wersji 1.7.6-1.

EDIT:
Ukazała się już wersja qt5-webengine 5.7.0-5, która problem zażegnała.